Atoms
Settings

プロジェクト設定

開いている Atoms プロジェクトを管理するには、プロジェクトメニューと Settings を使用します。このガイドは、サインイン済みでプロジェクトを開いているユーザー向けです。表示される内容は、あなたの役割、プラン、プロジェクトの状態、およびそのプロジェクトに利用可能なバージョンがあるかどうかによって異なります。

現在のメニューに関する注意。 現在の Settings メニューでは、Domains は Project の下に表示され、General は Workspace の下に表示されます。Project → General は現在表示されていません。ワークスペースに Project General パネルが表示されている場合は、それを選択してプロジェクトの概要を表示してください。表示されていない場合は、以下のプロジェクトメニューおよび設定パネルの手順を使用してください。

適切なコントロールを見つける

  1. Atoms でプロジェクトを開きます。
  2. 左上隅のプロジェクト名を選択します。
  3. Rename project または Remix this project を使用する場合は、プロジェクト名メニューを使用します。デスクトップで Unpublish または Delete を使用する場合は、そのメニューから Go to Dashboard を選択し、次にプロジェクトカードのアクションメニューを使用します。モバイルでは、アクションが表示されているときにプロジェクトメニューを使用します。
  4. 設定パネルを開くには、Settings を選択します。Project の下で Domains を選択し、Workspace の下で General を選択します。

ロールアウトで Project → General が表示されている場合は、それを選択してプロジェクトの概要とそのアクション領域を表示します。表示されていない場合は、隠れた General 項目を探し続けず、このガイドの個別の手順を使用してください。

プロジェクトの詳細を確認する

Project General が利用可能な場合、その Overview には Project name、Status、Versions、および Created at が表示されます。そのアクション領域では、Rename project、Remix this project、Unpublish、および Delete を利用できます。これらの値は、現在開いているプロジェクトを示します。

プロジェクト名を変更する

  1. プロジェクト名メニューを開き、Rename project を選択します。プロジェクト名を変更する権限が必要です。
  2. 新しいプロジェクト名を入力し、Save を選択します。名前にはスペースや特殊文字を含めることができ、長さはダイアログに表示されるフィールドの制限に従います。

期待される結果。 成功メッセージが表示され、新しい名前がプロジェクトメニューとプロジェクト詳細に表示されます。

Rename が利用できない場合。 あなたがプロジェクト所有者であるか、または必要な権限を持っていることを確認してください。プロジェクトを更新して再試行してください。それでもアクションが利用できない場合は、プロジェクト名と表示されたメッセージを添えて、ワークスペース管理者または Atoms サポートに連絡してください。

公開 URL のサブドメインを変更する

  1. プロジェクト名メニューを開き、Settings を選択し、Project の下で Domains を選択します。
  2. ライブドメインカードで Edit を選択します。
  3. 小文字、数字、またはハイフンを使用してサブドメインを入力します。表示されている長さ制限を満たし、利用可能である必要があります。
  4. エディターに表示されるドメイン接尾辞を含むプレビューを確認し、Update を選択します。

期待される結果。 Domains パネルに更新されたライブアドレスが表示されます。接尾辞は環境によって異なる場合があるため、固定の例ではなく Atoms に表示されるものを使用してください。

値が拒否される場合。 サポートされていない文字を削除し、表示されている長さ制限を満たすか、利用可能なサブドメインを選択してください。ライブドメインカードまたは Edit アクションが表示されない場合は、まず公開するかドメインを連携してください。

公開リンクから Atoms バッジを削除する

  1. プロジェクト名メニューを開き、Settings を選択し、Workspace の下で General を選択します。
  2. Remove Atoms™ Badge を見つけ、コントロールが有効になっている場合はオンにします。

これはプロジェクトごとの設定ではなく、公開リンクに対するワークスペースレベルの設定です。対象プランと、エディター以上の権限が必要です。トグルが無効になっている場合は、ワークスペースのエディターまたは所有者に変更を依頼するか、Plans and credits に表示されるプランを確認してください。

期待される結果。 設定が反映された後、ワークスペース内の公開リンクに Atoms バッジが表示されなくなります。

プロジェクトをリミックスする

  1. プロジェクト名メニューを開いて Remix this project を選択するか、Project General またはプロジェクトカードメニューに表示されている Remix アクションを使用します。
  2. 現在のバージョンを確認し、新しいプロジェクトの名前を入力します。
  3. Atoms に Copy database data または Sync ads to the new project が表示される場合は、各オプションを確認し、そのデータまたは同期をコピーしたい場合にのみ選択してください。
  4. Remix を選択して新しいプロジェクトを作成します。

これらのオプションは、対応するデータまたは広告を持つ、対象の所有プロジェクトにのみ表示されます。広告の同期を選択した場合、キャンペーンは現在のドメインに適用されます。今後変更するには、現在のプロジェクトからドメインの接続を解除し、新しいプロジェクトに接続する必要があります。

期待される結果。 新しいプロジェクトが開き、引き続き編集できる状態になります。Remix が無効になっている場合は、利用可能なバージョンが存在すること、およびプロジェクトをリミックスする権限があることを確認してください。

プロジェクトの公開を取り下げる

  1. プロジェクト一覧から、プロジェクトカードのアクションメニューを開いて Unpublish を選択します。Project General が表示されている場合は、そこにある Unpublish アクションを代わりに使用できます。このアクションは、プロジェクトが公開されていて、かつそれを管理する権限がある場合にのみ利用できます。
  2. 確認画面に一覧表示されるすべてのリンクを確認します。公開を取り下げると、それらの公開リンクは利用できなくなり、そのリンクのソーシャル共有も機能しなくなりますが、後で新しいリンクを再度公開することはできます。
  3. Yes, I confirmed を選択します。プロジェクトを公開状態のままにするには Cancel を選択します。

期待される結果。 一覧表示されたリンクは公開リンクとして応答しなくなりますが、プロジェクト自体は Atoms に残ります。アクションでエラーが報告された場合は、再試行する前に一覧表示されたリンクとプロジェクトの状態を確認してください。すでに利用できないリンクがある場合、またはエラーが続く場合は、アクションを繰り返さず、プロジェクト名とエラー内容を添えて Atoms サポートに連絡してください。

プロジェクトを削除する

プロジェクトの削除は元に戻せません。 確認する前に、必要になる可能性があるものは File → Download を使用して保存してください。

  1. プロジェクト一覧から、プロジェクトカードのアクションメニューを開いて Delete を選択します。モバイルでは、プロジェクトメニューから Delete を選択できます。Project General が表示されている場合は、そこにある Delete アクションを代わりに使用できます。
  2. Confirm deletion? で警告を確認します。Project General のフローでは Delete と Cancel のみが提供され、内部プロジェクトファイルは保持されます。Clean the disk やファイル保持の選択項目は提供されません。
  3. 完了するには Delete を選択し、プロジェクトを変更せずに残すには Cancel を選択します。

期待される結果。 プロジェクトはプロジェクト一覧から削除されます。Project General から削除を確定した場合、内部プロジェクトファイルは保持されます。別のプロジェクト一覧またはモバイルの削除フローでは、ファイル保持の選択肢が表示される場合がありますが、それらの選択肢は Project General には属しません。

削除が利用できない場合、または結果が不明確な場合。 あなたの権限とプロジェクトのアクションメニューを確認してください。リクエストが失敗した後は、破壊的な操作を繰り返さないよう、再試行する前にプロジェクト一覧を確認してください。それでもリクエストが失敗する場合は、プロジェクト名、時刻、エラー内容を添えて、ワークスペース管理者または Atoms サポートに連絡してください。

このページは役に立ちましたか?

関連記事